Feeds:
Posts
Comments

Archive for August 25th, 2007

1. Check your Nokia 6610 configuration with wvdialconf

taufanlubis@zyrex:/etc$ sudo wvdialconf /etc/wvdial.conf

Editing `/etc/wvdial.conf’.

 

Scanning your serial ports for a modem.

 

ttyS0<*1>: ATQ0 V1 E1 — failed with 2400 baud, next try: 9600 baud

ttyS0<*1>: ATQ0 V1 E1 — failed with 9600 baud, next try: 115200 baud

ttyS0<*1>: ATQ0 V1 E1 — and failed too at 115200, giving up.

Modem Port Scan<*1>: S1 S2 S3

WvModem<*1>: Cannot get information for serial port.

ttyACM0<*1>: ATQ0 V1 E1 — OK

ttyACM0<*1>: ATQ0 V1 E1 Z — OK

ttyACM0<*1>: ATQ0 V1 E1 S0=0 — OK

ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 — OK

ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 — OK

ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK

ttyACM0<*1>: Modem Identifier: ATI — Nokia

ttyACM0<*1>: Speed 4800: AT — OK

ttyACM0<*1>: Speed 9600: AT — OK

ttyACM0<*1>: Speed 19200: AT — OK

ttyACM0<*1>: Speed 38400: AT — OK

ttyACM0<*1>: Speed 57600: AT — OK

ttyACM0<*1>: Speed 115200: AT — OK

ttyACM0<*1>: Speed 230400: AT — OK

ttyACM0<*1>: Speed 460800: AT — ��

ttyACM0<*1>: Speed 460800: AT — ��

ttyACM0<*1>: Speed 460800: AT — ��

ttyACM0<*1>: Max speed is 230400; that should be safe.

ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK

 

Found an USB modem on /dev/ttyACM0.

/etc/wvdial.conf<Warn>: Can’t open ‘/etc/wvdial.conf’ for reading: No such file or directory

/etc/wvdial.conf<Warn>: …starting with blank configuration.

Modem configuration written to /etc/wvdial.conf.

ttyACM0<Info>: Speed 230400; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0″

taufanlubis@zyrex:/etc$

 

2. Edit your wvdial.conf file at /etc

taufanlubis@zyrex:/etc$ sudo gedit /etc/wvdial.conf

[Dialer Defaults]

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

Modem Type = USB Modem

; Phone = <Target Phone Number>

ISDN = 0

; Username = <Your Login Name>

Init1 = ATZ

; Password = <Your Password>

Modem = /dev/ttyACM0

Baud = 230400

 

The configuration in my laptop is:

[Dialer Defaults]

Init1 = ATZ

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

Init3 = AT+GMM

Init4 = ATI1

Init5 = ATI2

Init6 = ATI3

Modem Type = USB Modem

ISDN = 0

Modem = /dev/ttyACM0

Baud = 56400

 

[Dialer PROXL]

Phone = *99***1#

Username = “xlgprs”

Password = “proxl”

Init7 = ATZ,”202.152.240.50″,”www.xlgrps.net”

 

Where I got the Init1, Init3, Init4, Init5, Init6, Modem Type, ISDN, Baud and Init7 data?

I took it from my nokia configuration in Windows System. Because, nokia still does not provide their software in linux. So, the easy way is just copy it to linux.

 

3. Check the configuration again to make sure everything is right.

taufanlubis@zyrex:~$ cat /etc/wvdial.conf

[Dialer Defaults]

Init1 = ATZ

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

Init3 = AT+GMM

Init4 = ATI1

Init5 = ATI2

Init6 = ATI3

Modem Type = USB Modem

ISDN = 0

Modem = /dev/ttyACM0

Baud = 56400

 

[Dialer PROXL]

Phone = *99***1#

Username = “xlgprs”

Password = “proxl”

Init7 = ATZ,”202.152.240.50″,”www.xlgrps.net

 

4. Set your setting in Nokia 6110 to your grps provider.

In this case, I use PRO XL (indonesia mobile service provider)

Open Menu > Service > Setting > Active service settings > XL GPRS

 

5. Test the connection

Plug in the CA42 cable to your Nokia 6110 and your computer.

taufanlubis@zyrex:~$ sudo wvdial PROXL

Password:

–> WvDial: Internet dialer version 1.56

–> Cannot get information for serial port.

–> Initializing modem.

–> Sending: ATZ

ATZ

OK

–> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

OK

–> Sending: AT+GMM

AT+GMM

Nokia 6610

OK

–> Sending: ATI1

ATI1

351350307697080

OK

–> Sending: ATI2

ATI2

V 5.65

19-Nov-04

NHL-4U

(c) Nokia.

OK

–> Sending: ATI3

ATI3

Nokia 6610

OK

–> Sending: ATZ,”202.152.240.50″,”www.xlgrps.net”

ATZ,”202.152.240.50″,”www.xlgrps.net”

OK

–> Modem initialized.

–> Sending: ATDT*99***1#

–> Waiting for carrier.

ATDT*99***1#

CONNECT

~[7f]}#@!}!} } }2}#}$@#}!}$}%\}”}&} }*} } g}%~

–> Carrier detected. Waiting for prompt.

~[7f]}#@!}!} } }2}#}$@#}!}$}%\}”}&} }*} } g}%~

–> PPP negotiation detected.

–> Starting pppd at Sat Aug 25 05:25:04 2007

–> Pid of pppd: 5978

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> Using interface ppp0

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> local IP address 172.26.8.127

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> remote IP address 10.6.6.6

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> primary DNS address 202.152.254.245

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> secondary DNS address 202.152.254.246

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

 

6. Test with a ping

taufanlubis@zyrex:~$ ping http://www.yahoo.com

PING http://www.yahoo-ht3.akadns.net (209.131.36.158) 56(84) bytes of data.

If you can see the Yahoo IP, mean, you are now connected to the internet.

Just press Ctrl-C to stop the PING proccess.

Now, you are ready to access……

Happy, trying…..

 

Why still I can not connect to the Internet?

This occurs if you still have the other connection setup in you computer, such as eth0 to LAN.

You may can use ifdown

taufanlubis@zyrex:/etc$ sudo ifdown eth0

It may work but also it may not work. Like me, I still can’t connect to the internet if I just use ifdown.

So, just change the configuration to:

System > Administration > Network > Connections > Wired connection

Set the configuration to ‘Automatic Configuration (DHCP)

 

 

Stop the internet connection

Press Ctrl-C to stop the connection

Caught signal 2: Attempting to exit gracefully…

–> Terminating on signal 15

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> Connect time 3.8 minutes.

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> pppd: �[05][06][08]([04][06][08]�[07][06][08]�[0c][06][08]8

–> [06][08]�

–> [06][08]

–> Disconnecting at Sat Aug 25 05:29:00 2007

taufanlubis@zyrex:~$

Read Full Post »

Follow

Get every new post delivered to your Inbox.

Join 76 other followers