Feeds:
Posts
Comments

Archive for October 25th, 2007

If you are searching a good tool to download videos from YouTube, I think PyTube will be suitable to your expectation. You can convert the videos directly to various selected formats.

What you need to run PyTube?

PyTube need GTK+ version 2.12.x to run.

Plus, few dependencies, which are:

  • ffmpeg2theora

  • vorbis-tools

  • mplayer

  • mencoder

  • youtube-dl

GTK+2.0

PyGTK 2

Notify Python

Zenity

But, don’t worry, you don’t have to think about that stuff.

 

Step 1. Download the package

What you have to do is just download the package program from: http://www.gnomefiles.org/app.php?soft_id=2172

For Ubuntu users, choose file: pytube_0.0.8.1-1_all.deb.

 

Step 2. Install the package

taufanlubis@zyrex:/media/hda5/Linux Download$ sudo dpkg -i pytube_0.0.8.1-1_all.deb

Selecting previously deselected package pytube.

(Reading database … 179818 files and directories currently installed.)

Unpacking pytube (from pytube_0.0.8.1-1_all.deb) …

dpkg: dependency problems prevent configuration of pytube:

pytube depends on ffmpeg2theora; however:

Package ffmpeg2theora is not installed.

pytube depends on vorbis-tools; however:

Package vorbis-tools is not installed.

pytube depends on mplayer; however:

Package mplayer is not installed.

pytube depends on mencoder; however:

Package mencoder is not installed.

pytube depends on youtube-dl; however:

Package youtube-dl is not installed.

dpkg: error processing pytube (–install):

dependency problems – leaving unconfigured

Errors were encountered while processing:

pytube

taufanlubis@zyrex:/media/hda5/Linux Download$

 

Just ignore that error and continue our process.

Add option ‘-f’, it will attempt to continue the process if the integrity check fails .

taufanlubis@zyrex:~$ sudo apt-get -f install

Reading package lists… Done

Building dependency tree

Reading state information… Done

Correcting dependencies… Done

The following extra packages will be installed:

ffmpeg2theora mencoder mplayer mplayer-skins vorbis-tools youtube-dl

Suggested packages:

w32codecs libdvdcss mplayer-doc ladspa-sdk

The following NEW packages will be installed:

ffmpeg2theora mencoder mplayer mplayer-skins vorbis-tools youtube-dl

0 upgraded, 6 newly installed, 0 to remove and 2 not upgraded.

1 not fully installed or removed.

Need to get 7425kB of archives.

After unpacking 19.1MB of additional disk space will be used.

Do you want to continue [Y/n]? y

Get:1 http://archive.ubuntu.com gutsy/universe ffmpeg2theora 0.19-1 [25.5kB]

Get:2 http://archive.ubuntu.com gutsy/main vorbis-tools 1.1.1-13build1 [99.3kB]

Get:3 http://archive.ubuntu.com gutsy/multiverse mplayer-skins 2-7 [70.3kB]

Get:4 http://archive.ubuntu.com gutsy/multiverse mplayer 2:1.0~rc1-0ubuntu13 [3866kB]

Get:5 http://archive.ubuntu.com gutsy/multiverse mencoder 2:1.0~rc1-0ubuntu13 [3356kB]

Get:6 http://archive.ubuntu.com gutsy/universe youtube-dl 2007.08.24-1 [7926B]

Fetched 7425kB in 1m2s (118kB/s)

Selecting previously deselected package ffmpeg2theora.

(Reading database … 179836 files and directories currently installed.)

Unpacking ffmpeg2theora (from …/ffmpeg2theora_0.19-1_i386.deb) …

Selecting previously deselected package vorbis-tools.

Unpacking vorbis-tools (from …/vorbis-tools_1.1.1-13build1_i386.deb) …

Selecting previously deselected package mplayer-skins.

Unpacking mplayer-skins (from …/mplayer-skins_2-7_all.deb) …

Selecting previously deselected package mplayer.

Unpacking mplayer (from …/mplayer_2%3a1.0~rc1-0ubuntu13_i386.deb) …

Selecting previously deselected package mencoder.

Unpacking mencoder (from …/mencoder_2%3a1.0~rc1-0ubuntu13_i386.deb) …

Selecting previously deselected package youtube-dl.

Unpacking youtube-dl (from …/youtube-dl_2007.08.24-1_all.deb) …

Setting up ffmpeg2theora (0.19-1) …

Setting up vorbis-tools (1.1.1-13build1) …

 

Setting up mplayer-skins (2-7) …

Setting up mplayer (2:1.0~rc1-0ubuntu13) …

 

Setting up mencoder (2:1.0~rc1-0ubuntu13) …

Setting up youtube-dl (2007.08.24-1) …

Setting up pytube (0.0.8.1-1) …

taufanlubis@zyrex:~$

 

Step 3. Open your PyTube application

After the installation process is completed, PyTube will be placed in ‘Sound & Video’ menu list as default.

Now, Just open Application > Sound & Video > PyTube

 

Step 3. Copy the YouTube video link to PyTube and start to download

Open Webbrowser (Firefox), type: www.youtube.com (note: You must have Flash ready to display the videos).

Choose any video that you want to download.

Copy the link and past into URL video link text box.

Click ‘Save in’ to choose the target directory for downloading

Click ‘Execute’ button to start.

pytube.png

Happy trying….

 

Read Full Post »

Follow

Get every new post delivered to your Inbox.

Join 70 other followers