Feeds:
Posts
Comments

Archive for January 22nd, 2008

Alien is a program that converts between Red Hat rpm, Debian deb, Stampede slp, Slackware tgz, and Solaris pkg file formats.

When do you need Alien?

At the time you want to install a program meanwhile the only package available is from another linux distribution. For an example, your linux package is Red Head Package (.rpm) but you are using Ubuntu which use Debian Package (.deb) then you will need Alien.

How to install the program?

taufanlubis@toshiba:/usr/src/sources$ sudo apt-get install alien

Reading package lists… Done

Building dependency tree

Reading state information… Done

The following packages were automatically installed and are no longer required:

python2.4-minimal python2.4 tango-icon-theme-common tango-icon-theme

Use ‘apt-get autoremove’ to remove them.

The following extra packages will be installed:

debhelper gettext html2text intltool-debian libbeecrypt6 libneon25 librpm4 po-debconf rpm

Suggested packages:

lsb-rpm lintian dh-make cvs gettext-doc

Recommended packages:

libmail-sendmail-perl libcompress-zlib-perl

The following NEW packages will be installed:

alien debhelper gettext html2text intltool-debian libbeecrypt6 libneon25 librpm4 po-debconf rpm

0 upgraded, 10 newly installed, 0 to remove and 0 not upgraded.

Need to get 4228kB of archives.

After unpacking 15.1MB of additional disk space will be used.

Do you want to continue [Y/n]? y

Get:1 http://archive.ubuntu.com gutsy/main html2text 1.3.2a-3build1 [90.6kB]

Get:2 http://archive.ubuntu.com gutsy/main gettext 0.16.1-2ubuntu3 [1552kB]

Get:3 http://archive.ubuntu.com gutsy/main intltool-debian 0.35.0+20060710.1 [31.6kB]

Get:4 http://archive.ubuntu.com gutsy/main po-debconf 1.0.9 [117kB]

Get:5 http://archive.ubuntu.com gutsy/main debhelper 5.0.51ubuntu3 [526kB]

Get:6 http://archive.ubuntu.com gutsy/main libbeecrypt6 4.1.2-6build1 [108kB]

Get:7 http://archive.ubuntu.com gutsy/main libneon25 0.25.5.dfsg-6build1 [103kB]

Get:8 http://archive.ubuntu.com gutsy/main librpm4 4.4.1-14.1ubuntu2 [991kB]

Get:9 http://archive.ubuntu.com gutsy/main rpm 4.4.1-14.1ubuntu2 [603kB]

Get:10 http://archive.ubuntu.com gutsy/main alien 8.68 [104kB]

Fetched 4228kB in 60s (69.9kB/s)

Selecting previously deselected package html2text.

(Reading database … 102722 files and directories currently installed.)

Unpacking html2text (from …/html2text_1.3.2a-3build1_i386.deb) …

Selecting previously deselected package gettext.

Unpacking gettext (from …/gettext_0.16.1-2ubuntu3_i386.deb) …

Selecting previously deselected package intltool-debian.

Unpacking intltool-debian (from …/intltool-debian_0.35.0+20060710.1_all.deb) …

Selecting previously deselected package po-debconf.

Unpacking po-debconf (from …/po-debconf_1.0.9_all.deb) …

Selecting previously deselected package debhelper.

Unpacking debhelper (from …/debhelper_5.0.51ubuntu3_all.deb) …

Selecting previously deselected package libbeecrypt6.

Unpacking libbeecrypt6 (from …/libbeecrypt6_4.1.2-6build1_i386.deb) …

Selecting previously deselected package libneon25.

Unpacking libneon25 (from …/libneon25_0.25.5.dfsg-6build1_i386.deb) …

Selecting previously deselected package librpm4.

Unpacking librpm4 (from …/librpm4_4.4.1-14.1ubuntu2_i386.deb) …

Selecting previously deselected package rpm.

Unpacking rpm (from …/rpm_4.4.1-14.1ubuntu2_i386.deb) …

Selecting previously deselected package alien.

Unpacking alien (from …/archives/alien_8.68_all.deb) …

Setting up html2text (1.3.2a-3build1) …

Setting up gettext (0.16.1-2ubuntu3) …

Setting up intltool-debian (0.35.0+20060710.1) …

Setting up po-debconf (1.0.9) …

Setting up debhelper (5.0.51ubuntu3) …

Setting up libbeecrypt6 (4.1.2-6build1) …

Setting up libneon25 (0.25.5.dfsg-6build1) …

Setting up librpm4 (4.4.1-14.1ubuntu2) …

Setting up rpm (4.4.1-14.1ubuntu2) …

Setting up alien (8.68) …

Processing triggers for libc6 …

ldconfig deferred processing now taking place

taufanlubis@toshiba:/usr/src/sources$ ls

How to use it?

Convert from RPM to DEB (alien -d)

But not all packages can be converted correctly. Some may still produce errors.

taufanlubis@toshiba:~/MyData/Packages$ sudo alien -d jre-6u2-linux-i586.rpm

Warning: Skipping conversion of scripts in package jre: postinst postrm prerm

Warning: Use the –scripts parameter to include the scripts.

jre_1.6.0_02-1_i386.deb generated

taufanlubis@toshiba:~/MyData/Packages$

Convert from DEB to RPM (alien-r)

You can convert also from DEB to RPM. Some work perfectly.

taufanlubis@toshiba:~/MyData/Packages$ sudo alien -r pytube_0.0.8.1-1_all.deb

pytube-0.0.8.1-2.noarch.rpm generated

taufanlubis@toshiba:~/MyData/Packages$

Read Full Post »

Open your root terminal.

Applications > Accessories > Terminal or Alt-F2 and type ‘gnome-terminal‘.

Then goto to Edit > Current Profile > Effects and change the value at ‘Transparent background‘.

transparent_terminal.png

You can also change the color of the font foreground and background.

terminal_color.png

So, you will have a better display.

 

terminal.png

 

Read Full Post »

Follow

Get every new post delivered to your Inbox.

Join 69 other followers